# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[url=([^][\s]+)](.*?)\[\/url]/<a href='$1' target='_blank'>$2<\/a>/g;t' <<< "[url=https://test.com]my link[/url]"