#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[url=([^][\s]+)](.*?)\[/url]"
Local $sString = "[url=https://test.com]my link[/url]"
Local $sSubst = "<a href='$1' target='_blank'>$2</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)