package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[url=([^][\s]+)](.*?)\[/url]`)
var str = `[url=https://test.com]my link[/url]`
var substitution = "<a href='$1' target='_blank'>$2</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}