#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\s|\p{Punct})@anybody(?=\p{Punct}|\s)"
Local $sString = "hello, @anybody! How are you?"
Local $sSubst = "text"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)