package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\t\{(ABC-\d{4}-\d+)\s?\}`)
var str = ` {ABC-2019-9810 ABC-2019-9813}
{ABC-2019-9810}
{ABC-2019-9810 ABC-2019-9813 ABC-2019-9813}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}