import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\t\\{(ABC-\\d{4}-\\d+)\\s?\\}";
final String string = " {ABC-2019-9810 ABC-2019-9813}\n"
+ " {ABC-2019-9810}\n"
+ " {ABC-2019-9810 ABC-2019-9813 ABC-2019-9813}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}