const regex = /\t\{(ABC-\d{4}-\d+)\s?\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\t\\{(ABC-\\d{4}-\\d+)\\s?\\}', 'gm')
const str = ` {ABC-2019-9810 ABC-2019-9813}
{ABC-2019-9810}
{ABC-2019-9810 ABC-2019-9813 ABC-2019-9813}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}