// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\t\{(ABC-\d{4}-\d+)\s?\}").unwrap();
let string = " {ABC-2019-9810 ABC-2019-9813}
{ABC-2019-9810}
{ABC-2019-9810 ABC-2019-9813 ABC-2019-9813}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}