#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(\/| |^)r *\/ *(?!(superstonk( |$|\/)|gme( |$|\/)|all( |$|\/)))\w*(\?|\/|\.| |$|!)"
Local $sString = "r/all" & @CRLF & _
"r/ALL" & @CRLF & _
"" & @CRLF & _
"r " & @CRLF & _
"" & @CRLF & _
"r/superstonk" & @CRLF & _
"R/SUPERSTONK" & @CRLF & _
"Word r/superstonk" & @CRLF & _
"word r/superstonk word" & @CRLF & _
"r/superstonk?" & @CRLF & _
"r/superstonk." & @CRLF & _
"r/superstonk!" & @CRLF & _
"r/superstonk " & @CRLF & _
"r /superstonk" & @CRLF & _
"https://www.reddit.com/r/Superstonk?utm_medium=android_app&utm_source=share" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"r/random" & @CRLF & _
"R/RANDOM" & @CRLF & _
"Word r/random" & @CRLF & _
"word r/random word" & @CRLF & _
"r/random?" & @CRLF & _
"r/superstonk." & @CRLF & _
"r/random!" & @CRLF & _
"r/random " & @CRLF & _
"r /random " & @CRLF & _
"https://www.reddit.com/r/random?utm_medium=android_app&utm_source=share" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")