using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\*+(?= +\S)|(?<! )(?<!\*(?=\S)[^*\n]*)(\*+)(?![\w*])";
string input = @"Input => Actual === Expected : Success
=========================================================================
A b*** c => A b³ c === A b³ c : true
A *b* c* => A *b* c¹ === A *b* c¹ : true
A *b* *c* d* => A *b* *c* d¹ === A *b* *c* d¹ : true
A *b* c* d** => A *b* c¹ d² === A *b* c¹ d² : true
** a b c => ² a b c === ² a b c : true
** a b*** c => ² a b³ c === ² a b³ c : true
A *bc* d** => A *bc* d** === A *bc* d² : false";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}