import re
regex = re.compile(r"((?:\w+\s+)*\w+),?\s*(?=\1\b)", flags=re.MULTILINE)
test_str = ("I, I, I am really wanting to go, but I I am not, am not able to do it.\n"
"you know, you know you know")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)