$re = '/\/rest\/v1\/add\/.+$/m';
$str = '/rest/v1/add/6asadadad
/rest/v1/add';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);