import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w\\.\\-]+$";
final String string = "Examples of valid names:\n\n"
+ "foo\n"
+ "foo_bar\n"
+ "foo-bar\n\n"
+ "Examples of invalid names:\n\n"
+ "foo bar\n"
+ "foo@bar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}