$re = '/(?=(?!^)[^\[\]]*?\[|[^\[\]]+$)/m';
$str = 'ABCDE[NOT]FGH
CCGF[NOT]HI
MPJ[NOT]L
MNA[NOT]PLJ[KAJ]SHD
MPJ[NOT]
[NOT]L
MNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]
MNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]SHDMNA[NOT][KAJ]';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;