import re
regex = re.compile(r"^[a-zA-z:\/0-9]+\.[a-zA-z0-9\-].+", flags=re.MULTILINE)
test_str = ("http://wwwgooglees.com\n"
"pepe.es\n"
"ALOnso.es.ese.eso.shda;lsd.sadfaw\n"
"g.co\n"
"123Ahsplas.edu.gAva.essssss\n"
"sergicampos112.com\n"
"https://rexex101.com\n\n\n\n"
"como maximo 127 dominios \n"
"nombre de dominio 253 char\n"
"cada level name maximo 63 char\n"
"level names lowercase uppercase, ascii,digitos y signo menos pero no puede empezar ni acabar en simbolo menos\n"
"top level no puede ser todo numeros")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")