// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-z:\/0-9]+\.[a-zA-z0-9\-].+").unwrap();
let string = "http://wwwgooglees.com
pepe.es
ALOnso.es.ese.eso.shda;lsd.sadfaw
g.co
123Ahsplas.edu.gAva.essssss
sergicampos112.com
https://rexex101.com
como maximo 127 dominios
nombre de dominio 253 char
cada level name maximo 63 char
level names lowercase uppercase, ascii,digitos y signo menos pero no puede empezar ni acabar en simbolo menos
top level no puede ser todo numeros";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}