use strict;
my $str = 'JIRA-1234-testing-node
JIRA-1234
feature/JIRA-1234-testing-node
bugfix/JIRA5-1234-testing-node
feature/jira-1234-testing-node
bugfix/JIRA-1234-testing-node
release/JIRA-1234-testing-node
hotfix/JIRA-1234-testing-node
TEST-TEST/JIRA-1234-testing-node-test
TEST-1234/JIRA-1234-testing-node_test
release/v1.0.1
release/v1.0.1-alpha
release/v1.0.1-alpha.0
release/v1.0.1-alpha,16
release/1.0.1
release/alpha
release/beta
release/latest
release/next
release/experimental
testing-node
experimenta
release-v1.6.1-test
staging
master
develope
release';
my $regex = qr/(?<branch>(?:(?<prefix>.*)\/)?(?<suffix>(?:(?:(?<issue>[A-Za-z0-9-]*-\d*)-)?(?<slug>.*))))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}