#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\S+\.\S{2,4}\/\S*"
Local $sString = "17:00:29 <%Amand> test.com/pin/59537845-blabla-test/" & @CRLF & _
"17:00:29 <%Amand> test.test.com/pin/59537845-blabla-test/" & @CRLF & _
"17:00:41 <%Amand> un "domaine.ext/..."" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")