using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:(\d)\1{8})|(?:(\d)\2{2}-\2{2}-\2{4})).*$";
string input = @"888888888
123456789
888-88-8888
123-45-6789
111-22-3333
333-33-3333";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}