const regex = new RegExp('\\d{11}\\b', 'gm')
const str = `00000000000 00000000001 00000000002 00000000003 00000000010 00000000011 00000000012 00000000014 00000000020 00000000021 00000000022 00000000024 00000000030 00000000031 00000000032 00000000034 00000000100 00000000101 00000000110 00000000111 00000000120 00000000121`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}