package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^"\t]*(?:""[^"\t]*)*"`)
var str = `"a""b","cdef "`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}