package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S*\d\S*)|([^\s\d]+)`)
var str = `Nike Air Max 97
Adidas NMD-R1
Nike Air Max 270`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}