$re = '/^(?!\s)[a-zA-Z\d$#@ ]{1,5}(?<!\s)$/m';
$str = 'Hell@
He @@
Hel@
Hell
Hel %
Hell%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);