using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"codez";
string input = @"(https\:\\\/\\\/[a-zA-Z]+\.phncdn\.com\\\/videos\\\/[0-9]+\\\/[0-9]+\\\/[0-9]+\\\/720P+\_[a-zA-Z0-9]+\_[0-9]+\.mp4\?)+[a-zA-Z0-9=& ]+(?=\""\})
(https\:\\\/\\\/[a-zA-Z]+\.phncdn\.com\\\/videos\\\/[0-9]+\\\/[0-9]+\\\/[0-9]+\\\/480P+\_[a-zA-Z0-9]+\_[0-9]+\.mp4\?)+[a-zA-Z0-9=& ]+(?=\""\})
(https\:\\\/\\\/[a-zA-Z]+\.phncdn\.com\\\/videos\\\/[0-9]+\\\/[0-9]+\\\/[0-9]+\\\/240P+\_[a-zA-Z0-9]+\_[0-9]+\.mp4\?)+[a-zA-Z0-9=& ]+(?=\""\})";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}