use strict;
my $str = 'Keep1⦅Delete1a
⦅Delete2⦆
Delete1b⦆Keep2a
Keep2b⦅Delete3⦆Keep3';
my $regex = qr/\u2985[^\u2985\u2986]*\u2986/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";