# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[[^\][]*\]//g;t' <<< "Keep1[Delete1a
[Delete2]
Delete1b]Keep2a
Keep2b[Delete3]Keep3"