#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:[+-])?(?:(?:0?\.[0-9]*)|(?:[1-9]+\.?[0-9]*))(?:[eE][+-]?(?:(?:0?\.[0-9]*)|(?:[0-9]+\.?[0-9]*)))?)|(0x[0-9a-fA-F]+)|(0[0-9]*)"
Local $sString = "Matching Groups:" & @CRLF & _
"===============================" & @CRLF & _
"Group 0x1: hexadecimal numbers" & @CRLF & _
"Group 02: octal numbers" & @CRLF & _
"Group 3: decimal numbers" & @CRLF & _
"" & @CRLF & _
"1, 04, 3., +1.2e4, -0.03E-4, -.456E+003, - 04, .e4, 1.3e" & @CRLF & _
"" & @CRLF & _
"-0.04e-03 0x024 0 0x 0xG 0xF 0xf 0x3.4 0123345" & @CRLF & _
"" & @CRLF & _
"-00 -0xf.3e0f 0xFF00233 e09 e0xk22"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")