# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<Description>([^<]+)\n//gm;t' <<< " <Description>TestData</Description>\n
Data</Description>\n
<Description>Test\n
"