// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(\{\"TimePeriod\":){1}.+?(false\}){1}"#).unwrap();
let string = "{\"TimePeriod\": {\"Start\": \"2017-03-01\", \"End\": \"2017-04-01\"}, \"Total\": {\"UnblendedCost\": {\"Amount\": \"2942.25119998\", \"Unit\": \"USD\"}, \"UsageQuantity\": {\"Amount\": \"20835\", \"Unit\": \"Hrs\"}}, \"Groups\": [], \"Estimated\": false},{\"TimePeriod\": {\"Start\": \"2017-04-01\", \"End\": \"2017-05-01\"}, \"Total\": {\"UnblendedCost\": {\"Amount\": \"2982.62609983\", \"Unit\": \"USD\"}, \"UsageQuantity\": {\"Amount\": \"21049\", \"Unit\": \"Hrs\"}}, \"Groups\": [], \"Estimated\": false},{\"TimePeriod\": {\"Start\": \"2017-05-01\", \"End\": \"2017-06-01\"}, \"Total\": {\"UnblendedCost\": {\"Amount\": \"1399.04829988\", \"Unit\": \"USD\"}, \"UsageQuantity\": {\"Amount\": \"23010\", \"Unit\": \"Hrs\"}}, \"Groups\": [], \"Estimated\": false},{\"TimePeriod\": {\"Start\": \"2017-06-01\", \"End\": \"2017-07-01\"}, \"Total\": {\"UnblendedCost\": {\"Amount\": \"962.47549987\", \"Unit\": \"USD\"}, \"UsageQuantity\": {\"Amount\": \"20049\", \"Unit\": \"Hrs\"}}, \"Groups\": [], \"Estimated\": false}
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}