# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^\s*([A-Z\s]*?(?:(ROYAL BANK)|(BARCLAY)).*)$"
test_str = ("ROYAL BANK OF CANADA\n"
"ROYAL BANK OF CANADA\n"
"THE ROYAL BANK OF SCOTLAND PLC\n"
"THE ROYAL BANK OF SCOTLAND PLC\n"
"ROYAL BANK OF CANADA CAYMAN ISLANDS\n"
"RBC ROYAL BANK (TRINIDAD AND TOBAGO), LTD.\n"
"RBC ROYAL BANK (TRINIDAD AND TOBAGO), LTD.\n"
"THE ROYAL BANK OF SCOTLAND INTERNATIONAL, LTD.\n"
"THE ROYAL BANK OF SCOTLAND INTERNATIONAL LTD.\n"
"ROYAL BANK OF SCOTLAND, N.V.\n"
"RBC ROYAL BANK (BAHAMAS), LTD.\n"
"ROYAL BANK OF SCOTLAND PLC\n"
"ROYAL BANK OF SCOTLAND PLC\n"
"BARCLAYS BANK PLC\n"
"BARCLAYS BANK DELAWARE\n"
"BARCLAYS BANK OF GHANA, LTD.\n"
"BARCLAYS BANK DELAWARE\n"
"BARCLAYCARD GERMANY\n"
"BARCLAYS BANK PLC\n"
"BARCLAYS BANK PLC")
subst = "\\0"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.