# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[[:^print:][:cntrl:]\s]|GIF89.{0,20})*<\?(?:php)?\s*\$yourmail\s*=.{0,40}?put your e-mail here.{0,190}?scam[\s\w]+by\s*walid\s*nabil.{0,70}?facebook\.com\/oreo0o.{0,50}?walid_nabil(?:[^>]+>\s*)?$"
test_str = ("<?php\n"
"$yourmail = 'Tuto42@yahoo.com'; // PUT YOUR E-MAIL HERE\n\n"
"//To Open This Page : domain.com/?wal=mart\n\n"
"/*\n"
"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$\n"
"$ $\n"
"$ THIS SCAM WAS CREATED BY Walid Nabil (OREOO) $\n"
"$ FB:https://www.facebook.com/OReo0o $\n"
"$ ICQ:https://icq.im/Walid_Nabil $\n"
"$ 2020 $\n"
"$ $\n"
"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$\n\n"
" .----------------. .----------------. .----------------. .----------------. .----------------. .----------------. \n"
"| .--------------. || .--------------. || .--------------. || .--------------. || .--------------. || .--------------. |\n"
"| | ____ | || | _______ | || | _________ | || | ____ | || | ____ | || | ____ | |\n"
"| | .' `. | || | |_ __ \\ | || | |_ ___ | | || | .' `. | || | .' `. | || | .' `. | |\n"
"| | / .--. \\ | || | | |__) | | || | | |_ \\_| | || | / .--. \\ | || | / .--. \\ | || | / .--. \\ | |\n"
"| | | | | | | || | | __ / | || | | _| _ | || | | | | | | || | | | | | | || | | | | | | |\n"
"| | \\ `--' / | || | _| | \\ \\_ | || | _| |___/ | | || | \\ `--' / | || | \\ `--' / | || | \\ `--' / | |\n"
"| | `.____.' | || | |____| |___| | || | |_________| | || | `.____.' | || | `.____.' | || | `.____.' | |\n"
"| | | || | | || | | || | | || | | || | | |\n"
"| '--------------' || '--------------' || '--------------' || '--------------' || '--------------' || '--------------' |\n"
" '----------------' '----------------' '----------------' '----------------' '----------------' '----------------' \n"
"*/\n"
"?>\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.