#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)en\/(?:(?!history).)*?\/"
Local $sString = "https://denissov.ru/en/barracuda_limited/" & @CRLF & _
"https://denissov.ru/en/barracuda_chronograph/" & @CRLF & _
"https://denissov.ru/en/barracuda_mechanical/" & @CRLF & _
"https://denissov.ru/en/speedster/" & @CRLF & _
"https://denissov.ru/en/free_rider/" & @CRLF & _
"https://denissov.ru/en/nau_automatic/" & @CRLF & _
"https://denissov.ru/en/lady_flower/" & @CRLF & _
"https://denissov.ru/en/enigma/" & @CRLF & _
"https://denissov.ru/en/number_one/" & @CRLF & _
"https://denissov.ru/en/history/" & @CRLF & _
"https://denissov.ru/en/wordhistory/" & @CRLF & _
"https://denissov.ru/en/historyword/" & @CRLF & _
"https://denissov.ru/en/histor_y/" & @CRLF & _
"" & @CRLF & _
"https://denissov.ru/en/barracuda_limited/', '_top')" style="cursor: pointer;""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")