#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z]*)\s*([\d\/\s\,]*)\s*(.*)$"
Local $sString = "17a Taylor Street" & @CRLF & _
"13/1 McDougall St" & @CRLF & _
"76 Lyndhurst street " & @CRLF & _
"PO Box 177" & @CRLF & _
"30 Sunbeam Road " & @CRLF & _
"Level 24, 17-24 Kippax St"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")