$re = '/[(0-9)*-[A-Z|a-z]+/m';
$str = '400101-C1-U22
420411-C1-U40
400200
412200-c1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);