package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)repository:\s+['"]?(?<depName>[_\-\/\w]+)['"]?,?\s+tag:\s+['"]?(?<currentValue>[_\-\.\w]+)['"]?`)
var str = ` image: { repository: user_name-123/repo_name-123, tag: v1.23.45_amd64-cluster }
image:
repository: "user_name-123/repo_name-123"
tag: 'v1.23.45_amd64-cluster'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}