package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\[](very sad)[^\]]`)
var str = `This is very sad and this is [very sad] and [test;very sad]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}