$re = '/[0-9]+([\.,]?[0-9]{1,2})?+[$€]/m';
$str = 'Un forfait de 2.99€ HT/an';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);