#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b[A-Z0-9a-z._%+-]+@gmail\.com\.net\b"
Local $sString = "123@gmail.com.net" & @CRLF & _
"12a.a.3@gmail.com.net" & @CRLF & _
"123@gmail.com.net" & @CRLF & _
"12a.a.3@gmoil.com.net" & @CRLF & _
"12a.a.3@gmoil"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")