import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "b\\.\\s(\\d{4})";
final String string = "21 Apr 1789 - 4 Mar 1797 John Adams (b. 1735 - d. 1826) Fed \n"
+ " 4 Mar 1797 - 4 Mar 1801 Thomas Jefferson (b. 1743 - d. 1826) D-R \n"
+ " 4 Mar 1801 - 4 Mar 1805 Aaron Burr (b. 1756 - d. 1836) D-R \n"
+ " 4 Mar 1805 - 20 Apr 1812 George Clinton (b. 1739 - d. 1812) D-R \n"
+ " 4 Mar 1813 - 23 Nov 1814 Elbridge Gerry (b. 1744 - d. 1814) D-R \n"
+ " 4 Mar 1817 - 4 Mar 1825 Daniel D. Tompkins (b. 1744 - d. 1825) D-R \n"
+ " 4 Mar 1825 - 28 Dec 1832 John Caldwell Calhoun (b. 1782 - d. 1850) Dem \n"
+ " 4 Mar 1833 - 4 Mar 1837 Martin van Buren (b. 1782 - d. 1862) Dem \n"
+ " 4 Mar 1837 - 4 Mar 1841 Richard Mentor Johnson (b. 1780 - d. 1850) Dem \n"
+ " 4 Mar 1841 - 4 Apr 1841 John Tyler (b. 1790 - d. 1862) Whg \n"
+ " 4 Mar 1845 - 4 Mar 1849 George Mifflin Dallas (b. 1792 - d. 1864) Dem ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}