$re = '/\b(?!2)\d/';
$str = '200
302
301
201
205
500';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);