package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[^\D2]`)
var str = `200
302
301
201
205
500`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}