package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d(\.\d{2}(\.\d{3})?)?$`)
var str = `1
1.98
1.98.123
1.123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}