const regex = /(<val>)(.*?,.*?,.*?,.*?,)(\s*.+?)(,.*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<val>)(.*?,.*?,.*?,.*?,)(\\s*.+?)(,.*$)', 'gm')
const str = `<val>5,0,10R,7,#1 Date Month text (Utility) Wordlist P4,null_val_func`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}