re = /(<val>)(.*?,.*?,.*?,.*?,)(\s*.+?)(,.*$)/m
str = '<val>5,0,10R,7,#1 Date Month text (Utility) Wordlist P4,null_val_func'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end