const regex = /\S@[^\s]+\s+(?<SPF_RESULT>[^ ]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S@[^\\s]+\\s+(?<SPF_RESULT>[^ ]+)', 'gm')
const str = `Oct 25 21:16:05 x.x.x.x Splunk_PIApp_MailLogs_QDC: Info: MID 92041462 SPF: mailfrom identity foo@bar.com SoftFail (v=spf1) `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}