re = /\S@[^\s]+\s+(?<SPF_RESULT>[^ ]+)/m
str = 'Oct 25 21:16:05 x.x.x.x Splunk_PIApp_MailLogs_QDC: Info: MID 92041462 SPF: mailfrom identity foo@bar.com SoftFail (v=spf1) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end