re = /^(ACD|AOC|AML|AMR|AS|BDC|BDH|BDS|BDW|BFW|BOW|BRW|BWH|BWL|BWM|BWV|CAA|CAC|CAD|CAE|CAR|CAT|CDM|CDR|CFD|CHD|CKE|CO2|CS|CSS|CWR|CWS|DEW|DIS|DMW|DRS|DSW|DW|FG|FLO|FO|FPF|FWS|HC|HCS|HFL|HFO|HPS|HOS|HRG|HSO|HYD|IA|LCS|LFL|LFO|LO|LPS|LSO|MDA|MET|MPSNG|NGP|NI|NIL|OFS|OG|OWS|PA|PR|PRA|PW|QO|QW|REH|REL|RFG|SAN|SCA|SCC|SHC|SCL|SCM|SCO|SCP|SEG|SEO|SFL|SOG|SOW|SSW|SUL|SVV|SW|SWD|SWR|SWS|TFL|TRM|TRW|VNT|VPS)/m
str = 'ACD
AOC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end