using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Article\s[0-9]+\b(?!\()";
string input = @"Article 29
Article 30(1)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}