re = /\\["']((?:[^"\\]|\\.)*)\\["']/m
str = 'summary = \\"Here is \\"summary\\"\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end