package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.{2})(.{2})(.{3})(.{2}).*`)
var str = `123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}